Raspberry PI 3 – minecraft server
1. Install Raspberrian on the SD card
# !! Instructions below are for OS X !! # List all connected disks diskutil list # Note down disk device (in this case it is /dev/disk1) # Make sure to use correct name !! # dd is super brutal and it will overwrite everything # without single question /dev/disk1 #: TYPE NAME SIZE IDENTIFIER 0: FDisk_partition_scheme *15.5 GB disk1 1: Windows_FAT_32 boot 62.9 MB disk1s1 2: Linux 4.0 GB disk1s2 # Unmount the disk # do not eject disk. If you do that, you will have to reconnect # card diskutil unmountDisk /dev/disk1 # Use dd to write raspberrian to SD # USE /dev/rdisk# instead of disk# # writing to /dev/disk# is dead slow sudo dd bs=1m if=~/raspbian-jessie.img of=/dev/rdisk1 conv=sync # in case it fail, you may need to use different device sudo dd bs=1m if=~/raspbian-jessie.img of=/dev/disk1 conv=sync
If you want to proceed with headless installation make sure to create empty file at /Volumes/boot. Otherwise you will not be able to connect via ssh. If you want to connect to your raspberry via ssh, simply call
ssh pi@raspberry-pi.address.goes.here password: raspberry
2. Make sure to Expand file system (take a look at my other post here)
3. Raspberrian Jessie already have Java preinstalled – so you don’t have to do anything here
4. Create directory for the server and download it there
mkdir mcserver cd mcserver curl "https://s3.amazonaws.com/Minecraft.Download/versions/1.9/minecraft_server.1.9.jar" -o minecraft_server.1.9.jar
5. Create server.properties file – you can use template below
spawn-protection=16 max-tick-time=60000 generator-settings= force-gamemode=false allow-nether=true gamemode=0 enable-query=false player-idle-timeout=0 difficulty=1 spawn-monsters=true op-permission-level=4 announce-player-achievements=true pvp=true snooper-enabled=true level-type=DEFAULT hardcore=false enable-command-block=false max-players=4 network-compression-threshold=256 resource-pack-sha1= max-world-size=10000 server-port=25565 server-ip= spawn-npcs=true allow-flight=false level-name=world view-distance=10 resource-pack= spawn-animals=true white-list=false generate-structures=true online-mode=true max-build-height=256 level-seed= motd=A Minecraft Server enable-rcon=false
6. Make sure to create eula.txt file with following content
#By changing the setting below #to TRUE you are indicating your agreement to our #EULA (https://account.mojang.com/documents/minecraft_eula). eula=true
7. Start server and enjoy :)
# You can play with memory settings, but remember # that you have 1GB for everything, so don't reserve too much # for the JVM java -Xms512M -Xmx512M -jar ./minecraft_server.1.9.jar -nogui